Archives for 

bug

PoC: Elevación de privilegios en el kernel Linux

Hace poco me entero de una nueva vulnerabilidad en el kernel de Linux, esta vez se trata de una vulnerabilidad, la cual permite escalar privilegios localmente en un sistema que tenga el kernel de Linux 2.6

El fallo fue descubierto por Jüri Aedla y  se debe a una incorrecta comprobación de privilegios al abrir el ‘/proc/#pid#/mem‘ de un proceso.

La informacion completa del fallo puede encontrarse en este link, alli explican paso a paso en que consiste la vulnerabilidad y como explotarla.

Esta es una vulnerabilidad grave, ya que  cualquier persona autorizada podria acceder como ROOT a cualquier sistema (obviamente que sea vulnerable) tan solo con estar fisicamente en el equipo y ejecutar el exploit.

En RinconInformatico.NET, se hizo la prueba de concepto con el fin de verificar  que tan facil seria para un atacante obtener una consola de root, y la verdad es que es bastante sencillo.

Se deben seguir los siguientes pasos:

  1. Se obtiene el codigo del exploit, elaborado en C, denominado por el autor como mempodipper
  2. Teniendo el codigo fuente del script, se procede a compilarlo:

    $ gcc mempodipper.c -o mempodipper

  3. Despues de compilar, solo resta ejecutar el binario y esperar  el resultado:
./mempodipper
Si todo ha salido bien, obtendremos root en unos pocos segundos:

 

Afortunadamente, las bondades del software libre permite que el bug sea corregido en tiempo record, aqui puedes ver el parche desarrollado por Linus Torvalds el cual soluciona la vulnerabilidad.

Solo queda esperar a que las diferentes distribuciones empaqueten la nueva version incluyendo el parche y actualizar de inmediato. Por su parte el proyecto Debian ya parcho casi todas las versiones, solo falta la version de wheezy, para la cual se debe esperar 10 dias a que la version en SID (ya parchada)  pase a testing.

Creepy ahora Disponible en Debian inestable.

Hace algun tiempo nuestro amigo Dragon nos enseño una excelente aplicacion llamada creepy, la cual nos permite  automatizar el proceso de extracción y localización de la información GPS publicada en las fotos por un usuario de , dejandola a la mano de cualquier persona.

Despues de conocer la aplicacion, usarla, y agregarla en mi set de herramientas preferidas, me di cuenta que alguien habia creado en  bug RFP en Debian,  ¿pero que quiere decir un bug RFP?

RFP(“Request for Package”):  Es un bug que se crea, cuando algun usuario de Debian encuentra un software interesante y desea que este sea incluido en Debian.

Al notar que esta magnifica aplicacion no se encontraba en Debian me hice cargo del bug y me puse en la tarea de empaquetar creepy para debian. Cabe resaltar que no soy experto empaquetando, pero poco a poco voy aprendiendo todos los trucos y metolodogias apropiadas para el buen empaquetamiento en debian, una distribucion muy estricta en cuanto a organizacion.

Despues de mucho trabajo, empeño, y conocimiento ( por que se aprendio mucho empaquetando una aplicacion desde cero, nunca lo habia hecho) es un orgullo para mi decir que CREEPY ahora esta oficialmente en debian inestable y que despues de 10 dias pasara a testing. Por ultimo, agradecer al upstream: “Yiannis Kakavas” por su apoyo y disposicion en colaborar con los cambios que habia que realizar, muchas gracias!!

Para aquellos usuarios de SID que deseen probarlo:

apt-get install creepy

Espero que lo prueben, y me den sus  comentarios y recomendanciones

Nuevas vulnerabilidades en OpenFire <=3.6.4

openfire 3.6.4

OpenFire, es una solucion libre  muy utilizada en el ambiente laboral  para aspectos de Colaboración (Chat, envio de archivos, salones de conferencias) que usa el protocolo Jabber (si el mismo de Google Talk) para proveer a sus usuarios de servicios de mensajeria instantanea, es extensible a hacer video conferencia y se puede integrar con Asterisk para hacer llamadas. Anteriormente aqui en RinconInformatico.NET hemos escrito algunas entradas sobre esta magnifica herramienta.

Sin embargo, reciemente se han descubierto algunos fallos GRAVES de seguridad en la ultima version (3.6.4), los cuales permiten a  un atacante  ejecutar funciones como un usuario autenticado y hacer peticiones al servidor. El ataque funciona mediante la inclusión de algunos enlaces  de secuencia de comandos en una página que tiene acceso a un sitio al que el usuario se conoce (O se supone) que han sido autenticados. Una explotación exitosa de estas vulnerabilidades podría resultar en,  comprometer toda la aplicacion, el robo de credenciales de autenticación basado en cookies, redirección de la página arbitraria, la divulgación o modificación de datos sensibles y ataques de phishing.

En exploit-db se ha publicado toda la informacion del fallo de seguridad, y una prueba de concepto.  Alli nos muestran claramente como de una forma muy sencilla se puede explotar la vulnerabilidad y comprometer la seguridad del sistema.

Recomendamos a todos aquellos que usen openfire estar pendiente de la pagina oficial,  esperando la solucion a este grave fallo.

Joomscan: Escanner de vulnerabilidades para Joomla

Existen muchas herramientas como w3af, acunetixo el mismo nessus,  que nos ayudan en el proceso de encontrar vulnerabilidades en  aplicaciones web. Sin embargo hace poco encontré un scanner el cual se especializa en portales Joomla(para quienes no saben que es Joomla hacer click aqui). Tuve la oportunidad de probar la aplicacion  y me gusta bastante, entre sus características tenemos:

  • Hecho en Perl
  • Permite actualizarse.
  • Reporte completo.
  • Interfaz web y por consola.
  • detecta vulnerabilidades como: SQL injection, LFI, RFI, XSS entre otros.
  • Se basa en OWASP.

Para descargar el  script pueden hacer click aqui. Obviamente como es hecho en perl, necesitamos tener instalado perl y algunas librerías:

apt-get install perl libwww-perl libtest-www-mechanize-perl

Para actualizarlo  hacemos lo siguiente:

chmod 777 joomscan.pl

./joomscan.pl update

Hacer un simple escaneo:

./joomscan.pl -u url_joomla

El resultado  que nos arroja es muy explicito, dice la vulnerabilidad, la descripción y si es vulnerable o no. Joomscan un buen script que nos ayuda a  descubrir aquellos  fallos que se pueden explotar en nuestro portal Joomla.

Liberado Metasploit Framework 3.3

El pasado 17 de noviembre, y tras un año de desarrollo continuo, fue liberada la versión 3.3 de este excelente framework el cual es herramienta fundamental para cada individuo que este relacionado con la seguridad informática.

Algunas nuevas Características:

  • 120 nuevos Exploits
  • 100 modulos auxiliares
  • mas de 80 bugs corregidos

Para descargarlo pueden hacer click aca, y si tienen problemas con la instalación, en Rincon Informatico hemos hablado sobre la instalacion del metasploit en GNU/Linux.